svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
remove(3c)
Standard C Library Functions remove(3C)
NAME
remove - remove file
SYNOPSIS
#include <stdio.h>
int remove(const char *path);
DESCRIPTION
The remove() function causes the file or empty directory whose name is
the string pointed to by path to be no longer accessible by that name.
A subsequent attempt to open that file using that name will fail,
unless the file is created anew.
For files, remove() is identical to unlink(). For directories, remove()
is identical to rmdir().
See rmdir(2) and unlink(2) for a detailed list of failure conditions.
RETURN VALUES
Upon successful completion, remove() returns 0. Otherwise, it returns
−1 and sets errno to indicate an error.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
rmdir(2), unlink(2), attributes(7), standards(7)
Oracle Solaris 11.4 14 Aug 2002 remove(3C)