svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
raise(3c)
Standard C Library Functions raise(3C)
NAME
raise - send a signal to the executing thread
SYNOPSIS
#include <signal.h>
int raise(int sig);
DESCRIPTION
The raise() function sends the signal sig to the executing thread. If a
signal handler is called, the raise function does not return until
after the signal handler returns.
The effect of the raise function is equivalent to calling:
pthread_kill(pthread_self(), sig);
See the pthread_kill(3C) manual page for a detailed list of failure
conditions and the signal.h(3HEAD) manual page for a list of signals.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
pthread_kill(3C), pthread_self(3C), signal.h(3HEAD), attributes(7),
standards(7)
Oracle Solaris 11.4 16 Aug 2017 raise(3C)