svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
puts(3c)
Standard C Library Functions puts(3C)
NAME
puts, fputs - put a string on a stream
SYNOPSIS
#include <stdio.h>
int puts(const char *s);
int fputs(const char *s, FILE *stream);
DESCRIPTION
The puts() function writes the string pointed to by s, followed by a
NEWLINE character, to the standard output stream stdout (see intro(3)).
The terminating null byte is not written.
The fputs() function writes the null-terminated string pointed to by s
to the named output stream. The terminating null byte is not written.
The st_ctime and st_mtime fields of the file will be marked for update
between the successful execution of fputs() and the next successful
completion of a call to fflush(3C) or fclose(3C) on the same stream or
a call to exit(2) or abort(3C).
RETURN VALUES
On successful completion, both functions return the number of bytes
written; otherwise they return EOF and set errno to indicate the error.
ERRORS
Refer to fputc(3C).
USAGE
Unlike puts(), the fputs() function does not write a NEWLINE character
at the end of the string.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
exit(2), write(2), fflush(3C), abort(3C), fclose(3C), ferror(3C),
fopen(3C), fputc(3C), printf(3C), stdio(3C), intro(3), attributes(7),
standards(7)
Oracle Solaris 11.4 18 Jun 2003 puts(3C)