svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
ptsname(3c)
Standard C Library Functions ptsname(3C)
NAME
ptsname - get name of the slave pseudo-terminal device
SYNOPSIS
#include <stdlib.h>
char *ptsname(int fildes);
DESCRIPTION
The ptsname() function returns the name of the slave pseudo-terminal
device associated with a master pseudo-terminal device. fildes is a
file descriptor returned from a successful open of the master device.
ptsname() returns a pointer to a string containing the null-terminated
path name of the slave device of the form /dev/pts/N, where N is a non-
negative integer.
RETURN VALUES
Upon successful completion, the function ptsname() returns a pointer to
a string which is the name of the pseudo-terminal slave device. This
value points to a static data area that is overwritten by each call to
ptsname(). Upon failure, ptsname() returns NULL. This could occur if
fildes is an invalid file descriptor or if the slave device name does
not exist in the file system.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
open(2), grantpt(3C), openpty(3C), ttyname(3C), unlockpt(3C),
attributes(7), standards(7)
STREAMS Programming Guide
Oracle Solaris 11.4 9 Jul 2018 ptsname(3C)