svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_testcancel(3c)
Standard C Library Functions pthread_testcancel(3C)
NAME
pthread_testcancel - create cancellation point in the calling thread
SYNOPSIS
#include <pthread.h>
void pthread_testcancel(void);
DESCRIPTION
The pthread_testcancel() function forces testing for cancellation. This
is useful when you need to execute code that runs for long periods
without encountering cancellation points; such as a library routine
that executes long-running computations without cancellation points.
This type of code can block cancellation for unacceptable long periods
of time. One strategy for avoiding blocking cancellation for long peri‐
ods, is to insert calls to pthread_testcancel() in the long-running
computation code and to setup a cancellation handler in the library
code, if required.
RETURN VALUES
The pthread_testcancel() function returns void.
ERRORS
The pthread_testcancel() function does not return errors.
EXAMPLES
See cancellation(7) for an example of using pthread_testcancel() to
force testing for cancellation and a discussion of cancellation con‐
cepts.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_cleanup_pop(3C), pthread_cleanup_push(3C), pthread_exit(3C),
pthread_join(3C), pthread_setcancelstate(3C), pthread_setcancel‐
type(3C), setjmp(3C), intro(3), attributes(7), cancellation(7), condi‐
tion(7), standards(7)
NOTES
The pthread_testcancel() function has no effect if cancellation is dis‐
abled.
Use pthread_testcancel() with pthread_setcanceltype() called with its
canceltype set to PTHREAD_CANCEL_DEFERRED. The pthread_testcancel()
function operation is undefined if pthread_setcanceltype() was called
with its canceltype argument set to PTHREAD_CANCEL_ASYNCHRONOUS.
It is possible to kill a thread when it is holding a resource, such as
lock or allocated memory. If that thread has not setup a cancellation
cleanup handler to release the held resource, the application is "can‐
cel-unsafe". See attributes(7) for a discussion of Cancel-Safety,
Deferred-Cancel-Safety, and Asynchronous-Cancel-Safety.
Oracle Solaris 11.4 16 May 2014 pthread_testcancel(3C)