svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_setname_np(3c)
Standard C Library Functions pthread_setname_np(3C)
NAME
pthread_setname_np, pthread_getname_np - set and get the thread name
SYNOPSIS
#include <pthread.h>
int pthread_setname_np(pthread_t t, const char *name );
int pthread_getname_np(pthread_t t, char *buf, size_t len);
DESCRIPTION
The pthread_setname_np() function associates a name with a thread t.
The thread name is a string of length 31 bytes or less, UTF-8 encoded.
If the length of name is greater than 31, the excess bytes are silently
ignored.
The pthread_getname_np() function returns the name of the specified
thread t in buf. At most, len-1 non-null characters are copied into
buf. The returned thread name will be null-terminated.
RETURN VALUES
If successful, the pthread_setname_np() and pthread_getname_np() func‐
tions return 0. Otherwise, an error number is returned to indicate the
error. It is not an error for the target thread to be a zombie thread.
ERRORS
The pthread_setname_np() and pthread_getname_np() function will fail
if:
ESRCH The value specified by thread does not refer to an existing
thread.
The pthread_getname_np() function will fail if:
EINVAL buf is NULL.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
pthread_attr_init(3C), pthread_attr_setname_np(3C), attributes(7),
standards(7), threads(7)
Oracle Solaris 11.4 23 Dec 2014 pthread_setname_np(3C)