svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_setcanceltype(3c)
Standard C Library Functions pthread_setcanceltype(3C)
NAME
pthread_setcanceltype - set cancellation type of a thread
SYNOPSIS
#include <pthread.h>
int pthread_setcanceltype(int type, int *oldtype);
DESCRIPTION
The pthread_setcanceltype() function atomically sets the calling
thread's cancellation type to the specified type and, if oldtype is not
NULL, stores the previous cancellation type in oldtype. The type can be
either of the following:
PTHREAD_CANCEL_DEFERRED
This is the default. When cancellation is enabled (enabled cancel‐
lation is also the default), cancellation occurs when the target
thread reaches a cancellation point and a cancel is pending. When
cancellation is disabled, all cancellation requests to the target
thread are held pending.
PTHREAD_CANCEL_ASYNCHRONOUS
When cancellation is enabled, receipt of a pthread_cancel(3C) call
causes immediate cancellation. When cancellation is disabled, all
cancellation requests to the target thread are held pending; as
soon as cancellation is re-enabled, pending cancellations are exe‐
cuted immediately.
See cancellation(7) for the definition of a cancellation point and a
discussion of cancellation concepts. See pthread_setcancelstate(3C) for
explanations of enabling and disabling cancellation.
The pthread_setcanceltype() function is a cancellation point if type is
called with PTHREAD_CANCEL_ASYNCHRONOUS and the cancellation state is
PTHREAD_CANCEL_ENABLE.
RETURN VALUES
Upon successful completion, the pthread_setcanceltype() function
returns 0. Otherwise, an error number is returned to indicate the
error.
ERRORS
The pthread_setcanceltype() function will fail if:
EINVAL The specified type is not PTHREAD_CANCEL_DEFERRED or
PTHREAD_CANCEL_ASYNCHRONOUS.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_cancel(3C), pthread_cleanup_pop(3C), pthread_cleanup_push(3C),
pthread_exit(3C), pthread_join(3C), pthread_setcancelstate(3C),
pthread_testcancel(3C), setjmp(3C), attributes(7), cancellation(7),
condition(7), standards(7)
Oracle Solaris 11.4 16 May 2014 pthread_setcanceltype(3C)