svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_rwlockattr_init(3c)
Standard C Library Functions
pthread_rwlockattr_init(3C)
NAME
pthread_rwlockattr_init, pthread_rwlockattr_destroy - initialize or
destroy read-write lock attributes object
SYNOPSIS
#include <pthread.h>
int pthread_rwlockattr_init(pthread_rwlockattr_t *attr);
int pthread_rwlockattr_destroy(pthread_rwlockattr_t *attr);
DESCRIPTION
The pthread_rwlockattr_init() function initializes a read-write lock
attributes object attr with the default value for all of the attributes
defined by the implementation.
Results are undefined if pthread_rwlockattr_init() is called specifying
an already initialized read-write lock attributes object.
After a read-write lock attributes object has been used to initialize
one or more read-write locks, any function affecting the attributes
object (including destruction) does not affect any previously initial‐
ized read-write locks.
The pthread_rwlockattr_destroy() function destroys a read-write lock
attributes object. The effect of subsequent use of the object is unde‐
fined until the object is re-initialized by another call to
pthread_rwlockattr_init(). An implementation can cause pthread_rwlock‐
attr_destroy() to set the object referenced by attr to an invalid
value.
RETURN VALUES
If successful, the pthread_rwlockattr_init() and pthread_rwlock‐
attr_destroy() functions return 0. Otherwise, an error number is
returned to indicate the error.
ERRORS
The pthread_rwlockattr_init() function will fail if:
ENOMEM Insufficient memory exists to initialize the read-write lock
attributes object.
The pthread_rwlockattr_destroy() function may fail if:
EINVAL The value specified by attr is invalid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_rwlock_init(3C), pthread_rwlock_rdlock(3C),
pthread_rwlock_unlock(3C), pthread_rwlock_wrlock(3C), pthread_rwlock‐
attr_getpshared(3C), attributes(7), standards(7)
Oracle Solaris 11.4 24 Nov 2017
pthread_rwlockattr_init(3C)