svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_once(3c)
Standard C Library Functions pthread_once(3C)
NAME
pthread_once - initialize dynamic package
SYNOPSIS
#include <pthread.h>
pthread_once_t once_control = PTHREAD_ONCE_INIT;
int pthread_once(pthread_once_t *once_control,
void (*init_routine)(void));
DESCRIPTION
If any thread in a process with a once_control parameter makes a call
to pthread_once(), the first call will summon the init_routine(), but
subsequent calls will not. The once_control parameter determines
whether the associated initialization routine has been called. The
init_routine() is complete upon return of pthread_once().
pthread_once() is not a cancellation point; however, if the function
init_routine() is a cancellation point and is canceled, the effect on
once_control is the same as if pthread_once() had never been called.
The constant PTHREAD_ONCE_INIT is defined in the <pthread.h> header.
If once_control has automatic storage duration or is not initialized by
PTHREAD_ONCE_INIT, the behavior of pthread_once() is undefined.
RETURN VALUES
Upon successful completion, pthread_once() returns 0. Otherwise, an
error number is returned to indicate the error.
ERRORS
EINVAL once_control or init_routine is NULL.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
call_once(3C), attributes(7), standards(7)
NOTES
Solaris threads do not offer this functionality.
Oracle Solaris 11.4 21 Nov 2014 pthread_once(3C)