svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_mutexattr_setprioceiling(3c)
Standard C Library Functions
pthread_mutexattr_getprioceiling(3C)
NAME
pthread_mutexattr_getprioceiling, pthread_mutexattr_setprioceiling -
get or set prioceiling attribute of mutex attribute object
SYNOPSIS
#include <pthread.h>
int pthread_mutexattr_getprioceiling(
const pthread_mutexattr_t *restrict attr,
int *restrict prioceiling);
int pthread_mutexattr_setprioceiling(pthread_mutexattr_t *attr,
int prioceiling);
DESCRIPTION
The pthread_mutexattr_getprioceiling() and pthread_mutexattr_setprio‐
ceiling() functions, respectively, get and set the priority ceiling
attribute of a mutex attribute object pointed to by attr, which was
previously created by the pthread_mutexattr_init() function.
The prioceiling attribute contains the priority ceiling of initialized
mutexes. The values of prioceiling must be within the range of priori‐
ties defined by SCHED_FIFO.
The prioceiling attribute defines the priority ceiling of initialized
mutexes, which is the minimum priority level at which the critical sec‐
tion guarded by the mutex is executed. In order to avoid priority
inversion, the priority ceiling of the mutex must be set to a priority
higher than or equal to the highest priority of all the threads that
may lock that mutex.
The ceiling value should be drawn from the range of priorities for the
SCHED_FIFO policy. When a thread acquires such a mutex, the policy of
the thread at mutex acquisition should match that from which the ceil‐
ing value was derived (SCHED_FIFO, in this case). If a thread changes
its scheduling policy while holding a ceiling mutex, the behavior of
pthread_mutex_lock() and pthread_mutex_unlock() on this mutex is unde‐
fined. See pthread_mutex_lock(3C).
RETURN VALUES
Upon successful completion, the pthread_mutexattr_getprioceiling() and
pthread_mutexattr_setprioceiling() functions return 0. Otherwise, an
error number is returned to indicate the error.
ERRORS
The pthread_mutexattr_setprioceiling() function will fail if:
EINVAL The value specified by attr is NULL or prioceiling is
invalid.
The pthread_mutexattr_getprioceiling() and pthread_mutexattr_setprio‐
ceiling() functions may fail if:
EINVAL The value specified by attr or prioceiling is invalid.
EPERM The caller does not have the privilege to perform the opera‐
tion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_cond_init(3C), pthread_create(3C), pthread_mutex_init(3C),
pthread_mutex_lock(3C), sched_get_priority_min(3C), attributes(7),
standards(7)
Oracle Solaris 11.4 16 May 2014
pthread_mutexattr_getprioceiling(3C)