svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_mutexattr_init(3c)
Standard C Library Functions
pthread_mutexattr_init(3C)
NAME
pthread_mutexattr_init, pthread_mutexattr_destroy - initialize or
destroy mutex attributes object
SYNOPSIS
#include <pthread.h>
int pthread_mutexattr_init(pthread_mutexattr_t *attr);
int pthread_mutexattr_destroy(pthread_mutexattr_t *attr);
DESCRIPTION
The pthread_mutexattr_init() function initializes a mutex attributes
object attr with the default value for all of the attributes defined by
the implementation.
The effect of initializing an already initialized mutex attributes
object is undefined.
After a mutex attributes object has been used to initialize one or more
mutexes, any function affecting the attributes object (including
destruction) does not affect any previously initialized mutexes.
The pthread_mutexattr_destroy() function destroys a mutex attributes
object; the object becomes, in effect, uninitialized. An implementation
may cause pthread_mutexattr_destroy() to set the object referenced by
attr to an invalid value. A destroyed mutex attributes object can be
re-initialized using pthread_mutexattr_init(); the results of otherwise
referencing the object after it has been destroyed are undefined.
RETURN VALUES
Upon successful completion, pthread_mutexattr_init() and pthread_mutex‐
attr_destroy() return 0. Otherwise, an error number is returned to
indicate the error.
ERRORS
The pthread_mutexattr_init() function may fail if:
ENOMEM Insufficient memory exists to initialize the mutex attributes
object.
The pthread_mutexattr_destroy() function may fail if:
EINVAL The value specified by attr is invalid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_cond_init(3C), pthread_create(3C), pthread_mutex_init(3C),
pthread_mutexattr_settype(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014
pthread_mutexattr_init(3C)