svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_mutexattr_getpshared(3c)
Standard C Library Functions
pthread_mutexattr_getpshared(3C)
NAME
pthread_mutexattr_getpshared, pthread_mutexattr_setpshared - get or set
process-shared attribute
SYNOPSIS
#include <pthread.h>
int pthread_mutexattr_getpshared(
const pthread_mutexattr_t *restrict attr,
int *restrict pshared);
int pthread_mutexattr_setpshared(pthread_mutexattr_t *attr,
int pshared);
DESCRIPTION
The pthread_mutexattr_getpshared() function obtains the value of the
process-shared attribute from the attributes object referenced by attr.
The pthread_mutexattr_setpshared() function is used to set the process-
shared attribute in an initialized attributes object referenced by
attr.
The process-shared attribute is set to PTHREAD_PROCESS_SHARED to permit
a mutex to be operated upon by any thread that has access to the memory
where the mutex is allocated, even if the mutex is allocated in memory
that is shared by multiple processes. If the process-shared attribute
is PTHREAD_PROCESS_PRIVATE, the mutex will only be operated upon by
threads created within the same process as the thread that initialized
the mutex; if threads of differing processes attempt to operate on such
a mutex, the behavior is undefined. The default value of the attribute
is PTHREAD_PROCESS_PRIVATE.
RETURN VALUES
Upon successful completion, pthread_mutexattr_getpshared() returns 0
and stores the value of the process-shared attribute of attr into the
object referenced by the pshared parameter. Otherwise, an error number
is returned to indicate the error.
Upon successful completion, pthread_mutexattr_setpshared() returns 0.
Otherwise, an error number is returned to indicate the error.
ERRORS
The pthread_mutexattr_getpshared() and pthread_mutexattr_setpshared()
functions may fail if:
EINVAL The value specified by attr is invalid.
The pthread_mutexattr_setpshared() function may fail if:
EINVAL The new value specified for the attribute is outside the
range of legal values for that attribute.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_cond_init(3C), pthread_create(3C), pthread_mutex_init(3C),
pthread_mutexattr_init(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014
pthread_mutexattr_getpshared(3C)