svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_mutex_setprioceiling(3c)
Standard C Library Functions
pthread_mutex_getprioceiling(3C)
NAME
pthread_mutex_getprioceiling, pthread_mutex_setprioceiling - change
priority ceiling of a mutex
SYNOPSIS
#include <pthread.h>
int pthread_mutex_getprioceiling(const pthread_mutex_t *restrict mutex,
int *restrict prioceiling);
int pthread_mutex_setprioceiling(pthread_mutex_t *restrict mutex,
int prioceiling, int *restrict old_ceiling);
DESCRIPTION
The pthread_mutex_getprioceiling() function returns the current prior‐
ity ceiling of the mutex.
The pthread_mutex_setprioceiling() function either locks the mutex if
it is unlocked, or blocks until it can successfully lock the mutex,
then it changes the mutex's priority ceiling and releases the mutex.
When the change is successful, the previous value of the priority ceil‐
ing is returned in old_ceiling. The process of locking the mutex need
not adhere to the priority protect protocol.
If the pthread_mutex_setprioceiling() function fails, the mutex prior‐
ity ceiling is not changed.
The ceiling value should be drawn from the range of priorities for the
SCHED_FIFO policy. When a thread acquires such a mutex, the policy of
the thread at mutex acquisition should match that from which the ceil‐
ing value was derived (SCHED_FIFO, in this case). If a thread changes
its scheduling policy while holding a ceiling mutex, the behavior of
pthread_mutex_lock() and pthread_mutex_unlock() on this mutex is unde‐
fined. See pthread_mutex_lock(3C).
The ceiling value should not be treated as a persistent value resident
in a pthread_mutex_t that is valid across upgrades of Solaris. The
semantics of the actual ceiling value are determined by the existing
priority range for the SCHED_FIFO policy, as returned by the
sched_get_priority_min() and sched_get_priority_max() functions (see
sched_get_priority_min(3C)) when called on the version of Solaris on
which the ceiling value is being utilized.
RETURN VALUES
Upon successful completion, the pthread_mutex_getprioceiling() and
pthread_mutex_setprioceiling() functions return 0. Otherwise, an error
number is returned to indicate the error.
ERRORS
The pthread_mutex_getprioceiling() and pthread_mutex_setprioceiling()
functions may fail if:
EINVAL The value specified by mutex does not refer to a currently
existing mutex.
The pthread_mutex_setprioceiling() function will fail if:
EINVAL The mutex was not initialized with its protocol attribute
having the value of PTHREAD_PRIO_PROTECT.
EINVAL The priority requested by prioceiling is out of range.
EPERM The caller does not have the privilege to perform the opera‐
tion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_mutex_init(3C), pthread_mutex_lock(3C), sched_get_prior‐
ity_min(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014
pthread_mutex_getprioceiling(3C)