svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_key_delete(3c)
Standard C Library Functions pthread_key_delete(3C)
NAME
pthread_key_delete - delete thread-specific data key
SYNOPSIS
#include <pthread.h>
int pthread_key_delete(pthread_key_t key);
DESCRIPTION
The pthread_key_delete() function deletes a thread-specific data key
previously returned by pthread_key_create(). The thread-specific data
values associated with key need not be NULL at the time
pthread_key_delete() is called. It is the responsibility of the appli‐
cation to free any application storage or perform any cleanup actions
for data structures related to the deleted key or associated thread-
specific data in any threads; this cleanup can be done either before or
after pthread_key_delete() is called. Any attempt to use key following
the call to pthread_key_delete() results in undefined behaviour.
The pthread_key_delete() function is callable from within destructor
functions. No destructor functions will be invoked by
pthread_key_delete(). Any destructor function that may have been asso‐
ciated with key will no longer be called upon thread exit.
RETURN VALUES
If successful, the pthread_key_delete() function returns 0. Otherwise,
an error number is returned to indicate the error.
ERRORS
The pthread_key_delete() function may fail if:
EINVAL The key value is invalid.
The pthread_key_delete() function will not return an error code of
EINTR.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_key_create(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014 pthread_key_delete(3C)