svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_getconcurrency(3c)
Standard C Library Functions
pthread_getconcurrency(3C)
NAME
pthread_getconcurrency, pthread_setconcurrency - get or set level of
concurrency
SYNOPSIS
#include <pthread.h>
int pthread_getconcurrency(void);
int pthread_setconcurrency(int new_level);
DESCRIPTION
Unbound threads in a process may or may not be required to be simulta‐
neously active. By default, the threads implementation ensures that a
sufficient number of threads are active so that the process can con‐
tinue to make progress. While this conserves system resources, it may
not produce the most effective level of concurrency.
The pthread_setconcurrency() function allows an application to inform
the threads implementation of its desired concurrency level, new_level.
The actual level of concurrency provided by the implementation as a
result of this function call is unspecified.
If new_level is 0, it causes the implementation to maintain the concur‐
rency level at its discretion as if pthread_setconcurrency() was never
called.
The pthread_getconcurrency() function returns the value set by a previ‐
ous call to the pthread_setconcurrency() function. If the pthread_set‐
concurrency() function was not previously called, this function returns
0 to indicate that the implementation is maintaining the concurrency
level.
When an application calls pthread_setconcurrency() it is informing the
implementation of its desired concurrency level. The implementation
uses this as a hint, not a requirement.
If an implementation does not support multiplexing of user threads on
top of several kernel scheduled entities, the pthread_setconcurrency()
and pthread_getconcurrency() functions will be provided for source code
compatibility but they will have no effect when called. To maintain the
function semantics, the new_level parameter will be saved when
pthread_setconcurrency() is called so that a subsequent call to
pthread_getconcurrency() returns the same value.
RETURN VALUES
If successful, the pthread_setconcurrency() function returns 0. Other‐
wise, an error number is returned to indicate the error.
The pthread_getconcurrency() function always returns the concurrency
level set by a previous call to pthread_setconcurrency(). If the
pthread_setconcurrency() function has never been called, pthread_get‐
concurrency() returns 0.
ERRORS
The pthread_setconcurrency() function will fail if:
EINVAL The value specified by new_level is negative.
EAGAIN The value specific by new_level would cause a system resource
to be exceeded.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_init(3C), pthread_create(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014
pthread_getconcurrency(3C)