svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_equal(3c)
Standard C Library Functions pthread_equal(3C)
NAME
pthread_equal - compare thread IDs
SYNOPSIS
#include <pthread.h>
int pthread_equal(pthread_t t1, pthread_t t2);
DESCRIPTION
The pthread_equal() function compares the thread IDs t1 and t2.
RETURN VALUES
The pthread_equal() function returns a non-zero value if t1 and t2 are
equal. Otherwise, 0 is returned.
If t1 or t2 is an invalid thread ID, the behavior is undefined.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_create(3C), pthread_self(3C), attributes(7), standards(7)
NOTES
Solaris thread IDs do not require an equivalent function because the
thread_t structure is an unsigned int.
Oracle Solaris 11.4 16 May 2014 pthread_equal(3C)