svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_detach(3c)
Standard C Library Functions pthread_detach(3C)
NAME
pthread_detach - detach a thread
SYNOPSIS
#include <pthread.h>
int pthread_detach(pthread_t thread);
DESCRIPTION
The pthread_detach() function is used to indicate to the implementation
that storage for the thread thread can be reclaimed when that thread
terminates. In other words, pthread_detach() dynamically resets the
detachstate attribute of the thread to PTHREAD_CREATE_DETACHED. After a
successful call to this function, it would not be necessary to reclaim
the thread using pthread_join(). See pthread_join(3C). If thread has
not terminated, pthread_detach() will not cause it to terminate. The
effect of multiple pthread_detach() calls on the same target thread is
unspecified.
RETURN VALUES
If successful, pthread_detach() returns 0. Otherwise, an error number
is returned to indicate the error.
ERRORS
The pthread_detach() function will fail if:
EINVAL The implementation has detected that the value specified by
thread does not refer to a joinable thread.
ESRCH No thread could be found corresponding to that specified by
the given thread ID.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_create(3C), pthread_join(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014 pthread_detach(3C)