svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_condattr_setpshared(3c)
Standard C Library Functions
pthread_condattr_getpshared(3C)
NAME
pthread_condattr_getpshared, pthread_condattr_setpshared - get or set
process-shared condition variable attributes
SYNOPSIS
#include <pthread.h>
int pthread_condattr_getpshared(
const pthread_condattr_t *restrict attr,
int *restrict pshared);
int pthread_condattr_setpshared(pthread_condattr_t *attr,
int pshared);
DESCRIPTION
The pthread_condattr_getpshared() function obtains the value of the
process-shared attribute from the attributes object referenced by attr.
The pthread_condattr_setpshared() function is used to set the process-
shared attribute in an initialized attributes object referenced by
attr.
The process-shared attribute is set to PTHREAD_PROCESS_SHARED to permit
a condition variable to be operated upon by any thread that has access
to the memory where the condition variable is allocated, even if the
condition variable is allocated in memory that is shared by multiple
processes. If the process-shared attribute is PTHREAD_PROCESS_PRIVATE,
the condition variable will only be operated upon by threads created
within the same process as the thread that initialized the condition
variable; if threads of differing processes attempt to operate on such
a condition variable, the behavior is undefined. The default value of
the attribute is PTHREAD_PROCESS_PRIVATE.
Additional attributes, their default values, and the names of the asso‐
ciated functions to get and set those attribute values are implementa‐
tion-dependent.
RETURN VALUES
If successful, the pthread_condattr_setpshared() function returns 0.
Otherwise, an error number is returned to indicate the error.
If successful, the pthread_condattr_getpshared() function returns 0 and
stores the value of the process-shared attribute of attr into the
object referenced by the pshared parameter. Otherwise, an error number
is returned to indicate the error.
ERRORS
The pthread_condattr_getpshared() and pthread_condattr_setpshared()
functions may fail if:
EINVAL The value specified by attr is invalid.
The pthread_condattr_setpshared() function will fail if:
EINVAL The new value specified for the attribute is outside the
range of legal values for that attribute.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_cond_init(3C), pthread_condattr_init(3C), pthread_create(3C),
pthread_mutex_init(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 May 2014
pthread_condattr_getpshared(3C)