svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_setschedpolicy(3c)
Standard C Library Functions
pthread_attr_getschedpolicy(3C)
NAME
pthread_attr_getschedpolicy, pthread_attr_setschedpolicy - get or set
schedpolicy attribute
SYNOPSIS
#include <pthread.h>
int pthread_attr_getschedpolicy(const pthread_attr_t *restrict attr,
int *restrict policy);
int pthread_attr_setschedpolicy(pthread_attr_t *attr, int policy);
DESCRIPTION
The functions pthread_attr_setschedpolicy() and pthread_attr_getsched‐
policy(), respectively, set and get the schedpolicy attribute in the
attr argument.
Supported values of policy include SCHED_FIFO, SCHED_RR and
SCHED_OTHER, which are defined by the header <sched.h>. When threads
executing with the scheduling policy SCHED_FIFO or SCHED_RR are waiting
on a mutex, they acquire the mutex in priority order when the mutex is
unlocked.
See sched.h(3HEAD) for a description of all defined policy values.
Valid policy values can also be obtained from pthread_getschedparam(3C)
and sched_getscheduler(3C).
RETURN VALUES
If successful, the pthread_attr_setschedpolicy() and
pthread_attr_getschedpolicy() functions return 0. Otherwise, an error
number is returned to indicate the error.
ERRORS
The pthread_attr_setschedpolicy() or pthread_attr_getschedpolicy()
function may fail if:
EINVAL attr or policy is invalid.
USAGE
After these attributes have been set, a thread can be created with the
specified attributes using pthread_create(). Using these routines does
not affect the current running thread.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_init(3C), pthread_attr_setinheritsched(3C),
pthread_attr_setschedparam(3C), pthread_attr_setscope(3C), pthread_cre‐
ate(3C), pthread_getschedparam(3C), sched_getscheduler(3C),
sched.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 19 May 2014