svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_setname_np(3c)
Standard C Library Functions
pthread_attr_setname_np(3C)
NAME
pthread_attr_setname_np, pthread_attr_getname_np - set and get the
thread name
SYNOPSIS
#include <pthread.h>
int pthread_attr_setname_np(pthread_attr_t *attr, const char *name);
int pthread_attr_getname_np(pthread_attr_t *attr, char *buf, size_t len);
DESCRIPTION
The pthread_attr_setname_np() and pthread_attr_getname_np() functions
are used to set and get the threadname attribute in the attr object.
The default value for this attribute is NULL. The maximum length of the
threadname attribute is 31 bytes, UTF-8 encoded.
For pthread_attr_setname_np(), if the length of the name is greater
than 31, the excess bytes are silently ignored. For pthread_attr_get‐
name_np(), at most len-1 non-null characters are copied into buf. The
returned thread name will be null-terminated.
RETURN VALUES
Upon successful completion, these functions return a 0; otherwise, an
error number is returned to indicate the error.
ERRORS
The pthread_attr_setname_np() function will fail if:
EINVAL attr is NULL.
The pthread_attr_getname_np() function may fail if:
EINVAL attr or buf is NULL.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
pthread_attr_init(3C), pthread_setname_np(3C), attributes(7),
threads(7)
Oracle Solaris 11.4 6 Dec 2012
pthread_attr_setname_np(3C)