svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_setdetachstate(3c)
Standard C Library Functions
pthread_attr_getdetachstate(3C)
NAME
pthread_attr_getdetachstate, pthread_attr_setdetachstate - get or set
detachstate attribute
SYNOPSIS
#include <pthread.h>
int pthread_attr_setdetachstate(pthread_attr_t *attr,
int detachstate);
int pthread_attr_getdetachstate(const pthread_attr_t *attr,
int *detachstate);
DESCRIPTION
The detachstate attribute controls whether the thread is created in a
detached state. If the thread is created detached, then use of the ID
of the newly created thread by the pthread_detach() or pthread_join()
function is an error.
The pthread_attr_setdetachstate() and pthread_attr_getdetachstate(),
respectively, set and get the detachstate attribute in the attr object.
The detachstate can be set to either PTHREAD_CREATE_DETACHED or
PTHREAD_CREATE_JOINABLE. A value of PTHREAD_CREATE_DETACHED causes all
threads created with attr to be in the detached state, whereas using a
value of PTHREAD_CREATE_JOINABLE causes all threads created with attr
to be in the joinable state. The default value of the detachstate
attribute is PTHREAD_CREATE_JOINABLE.
RETURN VALUES
Upon successful completion, pthread_attr_setdetachstate() and
pthread_attr_getdetachstate() return a value of 0. Otherwise, an error
number is returned to indicate the error.
The pthread_attr_getdetachstate() function stores the value of the
detachstate attribute in detachstate if successful.
ERRORS
The pthread_attr_setdetachstate() or pthread_attr_getdetachstate()
functions may fail if:
EINVAL attr or detachstate is invalid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_init(3C), pthread_attr_setstackaddr(3C), pthread_attr_set‐
stacksize(3C), pthread_create(3C), attributes(7), standards(7)
Oracle Solaris 11.4 19 May 2014
pthread_attr_getdetachstate(3C)