svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_getstackaddr(3c)
Standard C Library Functions
pthread_attr_getstackaddr(3C)
NAME
pthread_attr_getstackaddr, pthread_attr_setstackaddr - get or set
stackaddr attribute
SYNOPSIS
#include <pthread.h>
int pthread_attr_getstackaddr(const pthread_attr_t *restrict attr,
void **restrict stackaddr);
int pthread_attr_setstackaddr(pthread_attr_t *attr, void *stackaddr);
DESCRIPTION
The functions pthread_attr_setstackaddr() and pthread_attr_getstack‐
addr(), respectively, set and get the thread creation stackaddr
attribute in the attr object. The stackaddr default is NULL. See
pthread_create(3C).
The stackaddr attribute specifies the location of storage to be used
for the created thread's stack. The size of the storage is at least
PTHREAD_STACK_MIN.
RETURN VALUES
Upon successful completion, pthread_attr_setstackaddr() and
pthread_attr_getstackaddr() return a value of 0. Otherwise, an error
number is returned to indicate the error.
If successful, the pthread_attr_getstackaddr() function stores the
stackaddr attribute value in stackaddr.
ERRORS
The pthread_attr_setstackaddr() function may fail if:
EINVAL attr is invalid.
The pthread_attr_getstackaddr() function may fail if:
EINVAL attr or stackaddr is invalid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_init(3C), pthread_attr_setdetachstate(3C),
pthread_attr_setstacksize(3C), pthread_create(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 16 May 2014
pthread_attr_getstackaddr(3C)