svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_getscope(3c)
Standard C Library Functions pthread_attr_getscope(3C)
NAME
pthread_attr_getscope, pthread_attr_setscope - get or set contention‐
scope attribute
SYNOPSIS
#include <pthread.h>
int pthread_attr_getscope(const pthread_attr_t *restrict attr,
int *restrict contentionscope);
int pthread_attr_setscope(pthread_attr_t *attr, int contentionscope);
DESCRIPTION
The pthread_attr_setscope() and pthread_attr_getscope() functions are
used to set and get the contentionscope attribute in the attr object.
The contentionscope attribute can have the value PTHREAD_SCOPE_SYSTEM,
signifying system scheduling contention scope, or
PTHREAD_SCOPE_PROCESS, signifying process scheduling contention scope.
The symbols PTHREAD_SCOPE_SYSTEM and PTHREAD_SCOPE_PROCESS are defined
by the header <pthread.h>.
RETURN VALUES
If successful, the pthread_attr_setscope() and pthread_attr_getscope()
functions return 0. Otherwise, an error number is returned to indicate
the error.
ERRORS
The pthread_attr_setscope(), or pthread_attr_getscope(), function may
fail if:
EINVAL attr or contentionscope is invalid.
USAGE
After these attributes have been set, a thread can be created with the
specified attributes using pthread_create(). Using these routines does
not affect the current running thread.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_init(3C), pthread_attr_setinheritsched(3C),
pthread_attr_setschedparam(3C), pthread_attr_setschedpolicy(3C),
pthread_create(3C), pthread_setschedparam(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 19 May 2014 pthread_attr_getscope(3C)