svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_getschedparam(3c)
Standard C Library Functions
pthread_attr_getschedparam(3C)
NAME
pthread_attr_getschedparam, pthread_attr_setschedparam - get or set
schedparam attribute
SYNOPSIS
#include <pthread.h>
int pthread_attr_getschedparam(const pthread_attr_t *restrict attr,
struct sched_param *restrict param);
int pthread_attr_setschedparam(pthread_attr_t *restrict attr,
const struct sched_param *restrict param);
DESCRIPTION
The functions pthread_attr_setschedparam() and pthread_attr_getsched‐
param(), respectively, set and get the scheduling parameter attributes
in the attr argument. The contents of the param structure are defined
in <sched.h>. The only required member of param is sched_priority.
RETURN VALUES
If successful, the pthread_attr_setschedparam() and
pthread_attr_getschedparam() functions return 0. Otherwise, an error
number is returned to indicate the error.
ERRORS
The pthread_attr_setschedparam() function may fail if:
EINVAL attr is invalid.
The pthread_attr_getschedparam() function may fail if:
EINVAL attr or param is invalid.
USAGE
After these attributes have been set, a thread can be created with the
specified attributes using pthread_create(). Using these routines does
not affect the current running thread.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_init(3C), pthread_attr_setinheritsched(3C),
pthread_attr_setschedpolicy(3C), pthread_attr_setscope(3C),
pthread_create(3C), pthread_setschedparam(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 19 May 2014
pthread_attr_getschedparam(3C)