svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
pthread_attr_getinheritsched(3c)
Standard C Library Functions
pthread_attr_getinheritsched(3C)
NAME
pthread_attr_getinheritsched, pthread_attr_setinheritsched - get or set
inheritsched attribute
SYNOPSIS
#include <pthread.h>
int pthread_attr_getinheritsched(const pthread_attr_t *restrict attr,
int *restrict inheritsched);
int pthread_attr_setinheritsched(pthread_attr_t *attr, int inheritsched);
DESCRIPTION
The functions pthread_attr_setinheritsched() and pthread_attr_getinher‐
itsched(), respectively, set and get the inheritsched attribute in the
attr argument.
When the attribute objects are used by pthread_create(), the inher‐
itsched attribute determines how the other scheduling attributes of the
created thread are to be set:
PTHREAD_INHERIT_SCHED Specifies that the scheduling policy and
associated attributes are to be inherited
from the creating thread, and the scheduling
attributes in this attr argument are to be
ignored.
PTHREAD_EXPLICIT_SCHED Specifies that the scheduling policy and
associated attributes are to be set to the
corresponding values from this attribute
object.
The symbols PTHREAD_INHERIT_SCHED and PTHREAD_EXPLICIT_SCHED are
defined in the header <pthread.h>.
RETURN VALUES
If successful, the pthread_attr_setinheritsched() and pthread_attr_get‐
inheritsched() functions return 0. Otherwise, an error number is
returned to indicate the error.
ERRORS
The pthread_attr_setinheritsched() or pthread_attr_getinheritsched()
functions may fail if:
EINVAL attr or inheritsched is invalid.
USAGE
After these attributes have been set, a thread can be created with the
specified attributes using pthread_create(). Using these routines does
not affect the current running thread.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
pthread_attr_getschedparam(3C), pthread_attr_init(3C),
pthread_attr_setschedpolicy(3C), pthread_attr_setscope(3C),
pthread_create(3C), pthread_setschedparam(3C), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 19 May 2014
pthread_attr_getinheritsched(3C)