svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
posix_spawnattr_setschedpolicy(3c)
Standard C Library Functions
posix_spawnattr_getschedpolicy(3C)
NAME
posix_spawnattr_getschedpolicy, posix_spawnattr_setschedpolicy - get
and set spawn-schedpolicy attribute of spawn attributes object
SYNOPSIS
#include <spawn.h>
#include <sched.h>
int posix_spawnattr_getschedpolicy(
const posix_spawnattr_t *restrict attr,
int *restrict schedpolicy);
int posix_spawnattr_setschedpolicy(posix_spawnattr_t *attr,
int schedpolicy);
DESCRIPTION
The posix_spawnattr_getschedpolicy() function obtains the value of the
spawn-schedpolicy attribute from the attributes object referenced by
attr.
The posix_spawnattr_setschedpolicy() function sets the spawn-schedpol‐
icy attribute in an initialized attributes object referenced by attr.
The spawn-schedpolicy attribute represents the scheduling policy to be
assigned to the new process image in a spawn operation (if
POSIX_SPAWN_SETSCHEDULER is set in the spawn-flags attribute). The
default value of this attribute is unspecified.
RETURN VALUES
Upon successful completion, posix_spawnattr_getschedpolicy() returns 0
and stores the value of the spawn-schedpolicy attribute of attr into
the object referenced by the schedpolicy parameter. Otherwise, an error
number is returned to indicate the error.
Upon successful completion, posix_spawnattr_setschedpolicy() returns 0.
Otherwise, an error number is returned to indicate the error.
ERRORS
These functions may fail if:
EINVAL The value specified by attr is invalid.
The posix_spawnattr_setschedpolicy() function may fail if:
EINVAL The value of the attribute being set is not valid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
posix_spawn(3C), posix_spawnattr_destroy(3C), posix_spawnattr_get‐
flags(3C), posix_spawnattr_getpgroup(3C), posix_spawnattr_getsched‐
param(3C), posix_spawnattr_getsigdefault(3C), posix_spawnattr_getsig‐
mask(3C), spawn.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 30 Jan 2004
posix_spawnattr_getschedpolicy(3C)