svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
posix_spawnattr_setflags(3c)
Standard C Library Functions
posix_spawnattr_getflags(3C)
NAME
posix_spawnattr_getflags, posix_spawnattr_setflags - get and set spawn-
flags attribute of spawn attributes object
SYNOPSIS
#include <spawn.h>
int posix_spawnattr_getflags(const posix_spawnattr_t *restrict attr,
short *restrict flags);
int posix_spawnattr_setflags(posix_spawnattr_t * attr, short flags);
DESCRIPTION
The posix_spawnattr_getflags() function obtains the value of the spawn-
flags attribute from the attributes object referenced by attr.
The posix_spawnattr_setflags() function sets the spawn-flags attribute
in an initialized attributes object referenced by attr.
The spawn-flags attribute is used to indicate which process attributes
are to be changed in the new process image when invoking
posix_spawn(3C) or posix_spawnp(3C). It is the bitwise inclusive-OR of
zero or more of the following flags:
POSIX_SPAWN_RESETIDS
POSIX_SPAWN_SETPGROUP
POSIX_SPAWN_SETSIGDEF
POSIX_SPAWN_SETSIGMASK
POSIX_SPAWN_SETSCHEDPARAM
POSIX_SPAWN_SETSCHEDULER
POSIX_SPAWN_NOSIGCHLD_NP
POSIX_SPAWN_WAITPID_NP
POSIX_SPAWN_NOEXECERR_NP
POSIX_SPAWN_SETSID
These flags are defined in <spawn.h>. The default value of this
attribute is as if no flags were set.
RETURN VALUES
Upon successful completion, posix_spawnattr_getflags() returns 0 and
stores the value of the spawn-flags attribute of attr into the object
referenced by the flags parameter. Otherwise, an error number is
returned to indicate the error.
Upon successful completion, posix_spawnattr_setflags() returns 0. Oth‐
erwise, an error number is returned to indicate the error.
ERRORS
These functions may fail if:
EINVAL The value specified by attr is invalid.
The posix_spawnattr_setflags() function may fail if:
EINVAL The value of the attribute being set is not valid.
EINVAL If both POSIX_SPAWN_SETPGROUP and POSIX_SPAWN_SETSID flags
are set in the spawn-flags attribute of the spawn attributes
object. These options are mutually exclusive.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
posix_spawn(3C), posix_spawnattr_destroy(3C), posix_spawnattr_getp‐
group(3C), posix_spawnattr_getschedparam(3C), posix_spawnattr_getsched‐
policy(3C), posix_spawnattr_getsigdefault(3C), posix_spawnattr_getsig‐
mask(3C), spawn.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 26 Mey 2020
posix_spawnattr_getflags(3C)