svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
posix_spawn_file_actions_destroy(3c)
Standard C Library Functions
posix_spawn_file_actions_destroy(3C)
NAME
posix_spawn_file_actions_destroy, posix_spawn_file_actions_init -
destroy and initialize spawn file actions object
SYNOPSIS
#include <spawn.h>
int posix_spawn_file_actions_destroy(
posix_spawn_file_actions_t *file_actions);
int posix_spawn_file_actions_init(
posix_spawn_file_actions_t *file_actions);
DESCRIPTION
The posix_spawn_file_actions_destroy() function destroys the object
referenced by file_actions. The object becomes, in effect, uninitial‐
ized. An implementation can cause posix_spawn_file_actions_destroy() to
set the object referenced by file_actions to an invalid value. A
destroyed spawn file actions object can be reinitialized using
posix_spawn_file_actions_init(). The results of otherwise referencing
the object after it has been destroyed are undefined.
The posix_spawn_file_actions_init() function initializes the object
referenced by file_actions to contain no file actions for
posix_spawn(3C) or posix_spawnp(3C) to perform.
A spawn file actions object is as defined in
posix_spawn_file_actions_addclose(3C).
The effect of initializing an already initialized spawn file actions
object is undefined.
RETURN VALUES
Upon successful completion, these functions return 0. Otherwise, an
error number is returned to indicate the error.
ERRORS
The posix_spawn_file_actions_init() function will fail if:
ENOMEM Insufficient memory exists to initialize the spawn file
actions object.
The posix_spawn_file_actions_destroy() function will may if:
EINVAL The value specified by file_actions is invalid.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
posix_spawn(3C), posix_spawn_file_actions_addclose(3C), spawn.h(3HEAD),
attributes(7), standards(7)
Oracle Solaris 11.4 30 Jan 2004
posix_spawn_file_actions_destroy(3C)