svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
posix_spawn_file_actions_adddup2(3c)
Standard C Library Functions
posix_spawn_file_actions_adddup2(3C)
NAME
posix_spawn_file_actions_adddup2 - add dup2 action to spawn file
actions object
SYNOPSIS
#include <spawn.h>
int posix_spawn_file_actions_adddup2(
posix_spawn_file_actions_t *file_actions, int fildes,
int newfildes);
DESCRIPTION
The posix_spawn_file_actions_adddup2() function adds a dup2(3C) action
to the object referenced by file_actions that causes the file descrip‐
tor fildes to be duplicated as newfildes (as if dup2(fildes, newfildes)
had been called) when a new process is spawned using this file actions
object.
If fildes and newfildes are equal, then the action shall ensure that
the FD_CLOEXEC and FD_CLOFORK flags of fildes are cleared (even though
dup2() would leave them unchanged).
A spawn file actions object is as defined in
posix_spawn_file_actions_addclose(3C).
RETURN VALUES
Upon successful completion, the posix_spawn_file_actions_adddup2()
function returns 0. Otherwise, an error number is be returned to indi‐
cate the error.
ERRORS
The posix_spawn_file_actions_adddup2() function will fail if:
EBADF The value specified by fildes or newfildes is negative or
greater than or equal to {OPEN_MAX}.
ENOMEM Insufficient memory exists to add to the spawn file actions
object.
The posix_spawn_file_actions_adddup2() function may fail if:
EINVAL The value specified by file_actions is invalid.
It is not considered an error for the fildes argument passed to
posix_spawn_file_actions_adddup2() to specify a file descriptor for
which the specified operation could not be performed at the time of the
call. Any such error will be detected when the associated file actions
object is later used during a posix_spawn(3C) or posix_spawnp(3C) oper‐
ation.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
dup2(3C), posix_spawn(3C), posix_spawn_file_actions_addclose(3C),
posix_spawn_file_actions_destroy(3C), spawn.h(3HEAD), attributes(7),
standards(7)
Oracle Solaris 11.4 24 Jun 2020
posix_spawn_file_actions_adddup2(3C)