svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
posix_spawn_file_actions_addclosefrom_np(3c)
Standard C Library Functions
posix_spawn_file_actions_addclosefrom_np(3C)
NAME
posix_spawn_file_actions_addclosefrom_np - add closefrom action to
spawn file actions object
SYNOPSIS
#include <spawn.h>
int posix_spawn_file_actions_addclosefrom_np(
posix_spawn_file_actions_t *file_actions, int lowfildes);
DESCRIPTION
The posix_spawn_file_actions_addclosefrom_np() function adds a close‐
from action to the object referenced by file_actions that causes all
open file descriptors greater than or equal to lowfildes to be closed
when a new process is spawned using this file actions object (see
closefrom(3C)).
A spawn file actions object is as defined in
posix_spawn_file_actions_addclose(3C).
RETURN VALUES
Upon successful completion, the posix_spawn_file_actions_addclose‐
from_np() function returns 0. Otherwise, an error number is returned to
indicate the error.
ERRORS
The posix_spawn_file_actions_addclosefrom_np() function will fail if:
EBADF The value specified by lowfildes is negative.
The posix_spawn_file_actions_addclosefrom_np() function may fail if:
EINVAL The value specified by file_actions is invalid.
ENOMEM Insufficient memory exists to add to the spawn file actions
object.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
close(2), closefrom(3C), posix_spawn(3C), posix_spawn_file_actions_add‐
close(3C), spawn.h(3HEAD), attributes(7)
Oracle Solaris 11.4 20 Feb 2009
posix_spawn_file_actions_addclosefrom_np(3C)