pci_config_setup(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

pci_config_setup(9f)

pci_config_setup(9F)           Kernel Functions           pci_config_setup(9F)



NAME
       pci_config_setup,   pci_config_teardown   -  setup  or  tear  down  the
       resources for enabling accesses to  the  PCI  Local  Bus  Configuration
       space

SYNOPSIS
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle);


       void pci_config_teardown(ddi_acc_handle_t *handle);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       dip       Pointer to the device's dev_info structure.


       handle    Pointer to a data access handle.


DESCRIPTION
       pci_config_setup()  sets up the necessary resources for enabling subse‐
       quent data accesses to the PCI Local Bus Configuration space.  pci_con‐
       fig_teardown()  reclaims and removes those resources represented by the
       data access handle returned from pci_config_setup().

RETURN VALUES
       pci_config_setup() returns:

       DDI_SUCCESS    Successfully setup the resources.


       DDI_FAILURE    Unable to allocate resources for setup.


CONTEXT
       pci_config_setup() must be called from user or kernel context. pci_con‐
       fig_teardown() can be called from any context.

NOTES
       These  functions  are  specific  to PCI bus device drivers. For drivers
       using these functions, a single source to support devices with multiple
       bus versions may not be easy to maintain.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ ArchitecturePCI Local Bus


SEE ALSO
       attributes(7)


       IEEE 1275 PCI Bus Binding



Oracle Solaris 11.4               1 Jan 1997              pci_config_setup(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3