svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
nvlist_remove_all(3nvpair)
Name-value Pair Library Functions nvlist_remove(3NVPAIR)
NAME
nvlist_remove, nvlist_remove_all - remove name-value pairs
SYNOPSIS
cc [ flag... ] file... -lnvpair [ library... ]
#include <libnvpair.h>
int nvlist_remove(nvlist_t *nvl, const char *name,
data_type_t type);
int nvlist_remove_all(nvlist_t *nvl, const char *name);
PARAMETERS
nvl The nvlist_t to be processed.
name Name of the name-value pair to be removed.
type Data type of the nvpair to be removed.
DESCRIPTION
The nvlist_remove() function removes the first occurrence of nvpair
that matches the name and the type.
The nvlist_remove_all() function removes all occurrences of nvpair that
match the name, regardless of type.
Multiple threads can simultaneously read the same nvlist_t but only one
thread can actively change a given nvlist_t at a time. The caller is
responsible for the synchronization.
RETURN VALUES
These functions return 0 on success and an error value on failure.
ERRORS
These functions will fail if:
EINVAL There is an invalid argument.
ENOENT No name-value pairs were found to match the criteria speci‐
fied by name and type.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.69i) |cw(2.81i) lw(2.69i) |lw(2.81i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
libnvpair(3LIB), attributes(7)
Oracle Solaris 11.4 2 Feb 2004 nvlist_remove(3NVPAIR)