svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
nl_langinfo(3c)
Standard C Library Functions nl_langinfo(3C)
NAME
nl_langinfo, nl_langinfo_l - language information
SYNOPSIS
#include <langinfo.h>
char *nl_langinfo(nl_item item);
char *nl_langinfo_l(nl_item item, locale_t locale);
DESCRIPTION
The nl_langinfo() and nl_langinfo_l() functions return a pointer to a
null-terminated string containing information relevant to a particular
language or cultural area defined in the current locale, or in the
locale represented by locale, respectively. The manifest constant names
and values of item are defined by <langinfo.h>. For example:
nl_langinfo (ABDAY_1);
would return a pointer to the string "dim" if the identified language
was Portuguese and Portuguese locale was correctly installed; or "Sun"
if the identified language was English.
nl_langinfo_l(ABDAY_1, loc);
would return a pointer to the string "dim" if the identified language
of the locale represented by loc was Portuguese and Portuguese locale
was correctly installed; or "Sun" if the identified language of the
locale represented by loc was English.
The behavior is undefined if the locale argument to nl_langinfo_l() is
the special locale object LC_GLOBAL_LOCALE or is not a valid locale
object handle.
RETURN VALUES
If setlocale(3C) has not been called successfully, or if data for a
supported language is either not available, or if item is not defined
therein, then nl_langinfo() returns a pointer to the corresponding
string in the C locale. In all locales, nl_langinfo() returns a pointer
to an empty string if item contains an invalid setting.
USAGE
The nl_langinfo() function can be used safely in multithreaded applica‐
tions, as long as setlocale(3C) is not being called to change the
locale.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilityCommitted _ MT-LevelMT-
Safe _ StandardSee standards(7).
SEE ALSO
duplocale(3C), freelocale(3C), newlocale(3C), setlocale(3C), uselo‐
cale(3C), langinfo.h(3HEAD), nl_types.h(3HEAD), attributes(7), stan‐
dards(7)
WARNINGS
The array pointed to by the return value should not be modified by the
program.
Oracle Solaris 11.4 10 Oct 2014 nl_langinfo(3C)