net_routeto(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

net_routeto(9f)

net_routeto(9F)                Kernel Functions                net_routeto(9F)



NAME
       net_routeto - indicate which network interface packets are sent

SYNOPSIS
       #include <sys/neti.h>

       phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address,
            struct sockaddr *nexthop);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net        value   returned   from  a  successful  call  to  net_proto‐
                  col_lookup(9F).


       address    network address to find a path out of the machine for.


       nexthop    pointer to the sockaddr structure  in  which  to  store  the
                  address  of  the  next  hop.  If  this  information  is  not
                  required, the value NULL may be passed instead.


DESCRIPTION
       The net_routeto() function indicates which  network  interface  packets
       destined  for  a  particular address would be sent out of, according to
       the systems network routing tables. If next is supplied as  a  non-NULL
       pointer, the IP address of the nexthop router to be used is returned in
       it.

RETURN VALUES
       The net_routeto() function returns:

       -1    The network protocol does not support this function.


       0     This function cannot find a route for the address given.


       >0    Indicates which network interface can be used to reach the  given
             address.


CONTEXT
       The  net_routeto()  function may be called from user, kernel, or inter‐
       rupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityCommit‐
       ted


SEE ALSO
       attributes(7),   net_phylookup(9F),   net_phygetnext(9F),    net_proto‐
       col_lookup(9F)



Oracle Solaris 11.4               1 May 2008                   net_routeto(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3