net_phygetnext(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

net_phygetnext(9f)

net_phygetnext(9F)             Kernel Functions             net_phygetnext(9F)



NAME
       net_phygetnext - search through the current list of network interfaces

SYNOPSIS
       #include <sys/neti.h>

       phy_if_t net_phygetnext(const net_data_t net, const phy_if_t ifp);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net    value   returned   from   a   successful   call   to  net_proto‐
              col_lookup(9F).


       ifp    value returned from  a  successful  call  to  this  function  or
              net_phylookup(9F).


DESCRIPTION
       The  net_phygetnext()  function  searches  through  all  of the network
       interfaces that a network protocol "owns". To start  searching  through
       all  of  the  interfaces  owned  by  a protocol, a value of 0 should be
       passed through as the value of ifp. When 0 is returned  by  this  func‐
       tion,  the  last  of  the  interfaces  owned  by this protocol has been
       reached.


       When called successfully,  the  value  returned  represents  a  network
       interface that exists, at the time of the call, within the scope of the
       network interface. This value is only guaranteed to  be  unique  for  a
       name within the scope of the network protocol.

EXAMPLES
            net_data_t net;
             phy_if_t ifp;
             char buffer[32];

             net = net_protocol_lookup("inet");

             if (net != NULL) {
                  for (ifp = net_phygetnext(net, 0); ifp != 0;
                       ifp = net_phygetnext(net, ifp)) {
                       /* Do something with ifp */
                       if (net_getifname(net, ifp, buffer,
                            sizeof(buffer) >= 0)
                             printf("Interface %s0, buffer);
                   }
               }





RETURN VALUES
       The  net_phygetnext() function returns -1 if it is not supported by the
       network protocol or 0 if an attempt  to  go  beyond  the  last  network
       interface is made. Otherwise, it returns a value representing a network
       interface.

CONTEXT
       The net_phygetnext() function may  be  called  from  user,  kernel,  or
       interrupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityCommit‐
       ted


SEE ALSO
       attributes(7), net_phylookup(9F), net_protocol_lookup(9F)



Oracle Solaris 11.4               1 May 2008                net_phygetnext(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3