net_isvalidchecksum(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

net_isvalidchecksum(9f)

net_isvalidchecksum(9F)        Kernel Functions        net_isvalidchecksum(9F)



NAME
       net_isvalidchecksum - verify layer 3 and layer 4  checksums

SYNOPSIS
       #include <sys/neti.h>

       int net_isvalidchecksum(const net_data_t net, mblk_t *mb);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net    value   returned   from   a   successful   call   to  net_proto‐
              col_lookup(9F).


       mb     the mblk structure holding a packet that is the subject of  this
              query.


DESCRIPTION
       The  net_isvalidchecksum() function verifies the layer 3 checksum (and,
       in some case, the layer 4 checksum) in the packet. If possible,  fields
       that  are  used by hardware checksum'ing are examined rather than manu‐
       ally verifying that the checksums are present for packets received from
       a network interface.


       For  both  IPv4 and IPv6, TCP, UDP and ICMP (including ICMPV6 for IPv6)
       layer 4 checksums are currently validated.

RETURN VALUES
       The net_isvalidchecksum() function returns:

       -1    The network protocol does not support this function.


       0     The packet does not contain partial checksums.


       1     The packet does contain partial checksums.


CONTEXT
       The net_isvalidchecksum() function may be called from user, kernel,  or
       interrupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityCommit‐
       ted


SEE ALSO
       attributes(7), net_ispartialchecksum(9F), net_protocol_lookup(9F)



Oracle Solaris 11.4               1 May 2008           net_isvalidchecksum(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3