net_ispartialchecksum(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

net_ispartialchecksum(9f)

net_ispartialchecksum(9F)      Kernel Functions      net_ispartialchecksum(9F)



NAME
       net_ispartialchecksum  -  indicate  if  a packet is being scheduled for
       hardware checksum calculation

SYNOPSIS
       #include <sys/neti.h>

       int net_ispartialchecksum(const net_data_t net, mblk_t *mb);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net    value  returned   from   a   successful   call   to   net_proto‐
              col_lookup(9F).


       mb     the  mblk structure holding a packet that is the subject of this
              query.


DESCRIPTION
       The net_ispartialchecksum() function looks at  the  fields  within  the
       mblk  structure  to  determine  if the packet contained inside contains
       headers with only partial checksum values. Partial checksum values  are
       stored  inside headers when the calculation of the complete checksum is
       being handled by the hardware.

RETURN VALUES
       The net_ispartialchecksum() function returns:

       -1    The network protocol does not support this function.


       0     The packet does not contain partial checksums.



       If a packet is marked for hardware checksum'ing, the  following  values
       are returned:

       NET_HCK_L3_FULL    Complete layer 3 checksum calculated


       NET_HCK_L3_PART    Partial layer 3 checksum calculated


       NET_HCK_L4_FULL    Complete layer 4 checksum calculated


       NET_HCK_L4_PART    Partial layer 4 checksum calculated


CONTEXT
       The  net_ispartialchecksum()  function may be called from user, kernel,
       or interrupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityCommit‐
       ted


SEE ALSO
       attributes(7), net_isvalidchecksum(9F), net_protocol_lookup(9F)



Oracle Solaris 11.4               1 May 2008         net_ispartialchecksum(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3