net_ifgroupgetnext(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

net_ifgroupgetnext(9f)

net_ifgroupgetnext(9F)         Kernel Functions         net_ifgroupgetnext(9F)



NAME
       net_ifgroupgetnext - search through the current list of firewall inter‐
       face groups attached to a particular network interface

SYNOPSIS
       #include <sys/neti.h>

       int net_ifgroupgetnext(net_handle_t net, phy_if_t ifp, char *prev,
       char *next);

PARAMETERS
       net     value  returned  from  a  successful  call  to  the  net_proto‐
               col_lookup() function


       ifp     value  returned from a successful call to net_phylookup() func‐
               tion


       prev    value of the next parameter set by the  previous  call  to  the
               net_ifgroupgetnext()   function.   The   first   call   to  the
               net_ifgroupgetnext() function is made by setting prev parameter
               to ""


       next    pointer  to  the  region  of  memory where the name of the next
               group in sequence is to be written. If the next  group  is  not
               found, the next parameter is set to ""



INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

DESCRIPTION
       The  net_ifgroupgetnext() function searches through all firewall inter‐
       face groups attached to the interface identified by the ifp  parameter.
       To start the search, a value of "" should be passed to the prev parame‐
       ter. When the next parameter is set to "", the last group  attached  to
       the  interface is reached. When called successfully, the value returned
       is 0. When there is a failure, -1 is returned.

RETURN VALUES
       The net_ifgroupgetnext() function returns -1 if there is an error, or 0
       if  lookup  is  successful.  In  case  there  are  no more groups, 0 is
       returned and next is set to "".

CONTEXT
       The net_ifgroupgetnext() function may be called from user,  kernel,  or
       interrupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityCommit‐
       ted


SEE ALSO
       net_phylookup(9F), net_protocol_lookup(9F), attributes(7)



Oracle Solaris 11.4               15 Mar 2016           net_ifgroupgetnext(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3