net_getifname(9f) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

net_getifname(9f)

net_getifname(9F)              Kernel Functions              net_getifname(9F)



NAME
       net_getifname - determine the name given to a network interface

SYNOPSIS
       #include <sys/neti.h>

       int net_getifname(const net_data_t net, const phy_if_t ifp,
            char *buffer, size_t buflen);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net       value   returned   from   a  successful  call  to  net_proto‐
                 col_lookup(9F).


       ifp       value returned from a successful call to net_phylookup(9F) or
                 net_phygetnext(9F).


       buffer    pointer to the buffer in which to write the interface name.


       buflen    size of the buffer in which to store the interface name.


DESCRIPTION
       The  net_getifname()  function copies the name of the network interface
       into the buffer provided. The name will always be  null-terminated.  If
       the  buffer  is  too small to fit both the interface name and the null-
       terminated name, the name in  the  buffer  is  truncated  to  fit.  See
       net_phygetnext(9F) for an example on how to use this function.

RETURN VALUES
       The net_getifname() function returns:

       -1    The network protocol does not support this function.


       0     Successful completion.


       1     Unsuccessful.


CONTEXT
       The net_getifname() function may be called from user, kernel, or inter‐
       rupt context.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/core-os _ Interface StabilityCommit‐
       ted


SEE ALSO
       net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)



Oracle Solaris 11.4               1 May 2008                 net_getifname(9F)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3