svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
nanosleep(3c)
Standard C Library Functions nanosleep(3C)
NAME
nanosleep - high resolution sleep
SYNOPSIS
#include <time.h>
int nanosleep(const struct timespec *rqtp,
struct timespec *rmtp);
DESCRIPTION
The nanosleep() function causes the current thread to be suspended from
execution until either the time interval specified by the rqtp argument
has elapsed or a signal is delivered to the calling thread and its
action is to invoke a signal-catching function or to terminate the
process. The suspension time may be longer than requested because the
argument value is rounded up to an integer multiple of the sleep reso‐
lution or because of the scheduling of other activity by the system.
But, except for the case of being interrupted by a signal, the suspen‐
sion time will not be less than the time specified by rqtp, as measured
by the system clock, CLOCK_REALTIME.
The use of the nanosleep() function has no effect on the action or
blockage of any signal.
RETURN VALUES
If the nanosleep() function returns because the requested time has
elapsed, its return value is 0.
If the nanosleep() function returns because it has been interrupted by
a signal, the function returns a value of −1 and sets errno to indicate
the interruption. If the rmtp argument is non-NULL, the timespec struc‐
ture referenced by it is updated to contain the amount of time remain‐
ing in the interval (the requested time minus the time actually slept).
If the rmtp argument is NULL, the remaining time is not returned.
If nanosleep() fails, it returns −1 and sets errno to indicate the
error.
ERRORS
The nanosleep() function will fail if:
EINTR The nanosleep() function was interrupted by a signal.
EINVAL The rqtp argument specified a nanosecond value less than zero
or greater than or equal to 1000 million.
ENOSYS The nanosleep() function is not supported by this implementa‐
tion.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
sleep(3C), time.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 5 Feb 2008 nanosleep(3C)