svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
mq_setattr(3c)
Standard C Library Functions mq_setattr(3C)
NAME
mq_setattr - set/get message queue attributes
SYNOPSIS
#include <mqueue.h>
int mq_setattr(mqd_t mqdes, const struct mq_attr *mqstat,
struct mq_attr *omqstat);
DESCRIPTION
The mq_setattr() function is used to set attributes associated with the
open message queue description referenced by the message queue descrip‐
tor specified by mqdes.
The message queue attributes corresponding to the following members
defined in the mq_attr structure are set to the specified values upon
successful completion of mq_setattr():
mq_flags The value of this member is either 0 or O_NONBLOCK.
The values of mq_maxmsg, mq_msgsize, and mq_curmsgs are ignored by
mq_setattr().
If omqstat is non-NULL, mq_setattr() stores, in the location referenced
by omqstat, the previous message queue attributes and the current queue
status. These values are the same as would be returned by a call to
mq_getattr() at that point.
RETURN VALUES
Upon successful completion, mq_setattr() returns 0 and the attributes
of the message queue will have been changed as specified. Otherwise,
the message queue attributes are unchanged, and the function returns −1
and sets errno to indicate the error.
ERRORS
The mq_setattr() function will fail if:
EBADF The mqdes argument is not a valid message queue descriptor.
ENOSYS The mq_setattr() function is not supported by the system.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
msgctl(2), msgget(2), msgrcv(2), msgsnd(2), mq_getattr(3C),
mq_open(3C), mq_receive(3C), mq_send(3C), mqueue.h(3HEAD),
attributes(7), standards(7)
Oracle Solaris 11.4 31 Jan 2012 mq_setattr(3C)