svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
mq_getattr(3c)
Standard C Library Functions mq_getattr(3C)
NAME
mq_getattr - get message queue attributes
SYNOPSIS
#include <mqueue.h>
int mq_getattr(mqd_t mqdes, struct mq_attr *mqstat);
DESCRIPTION
The mqdes argument specifies a message queue descriptor. The
mq_getattr() function is used to get status information and attributes
of the message queue and the open message queue description associated
with the message queue descriptor. The results are returned in the
mq_attr structure referenced by the mqstat argument.
Upon return, the following members will have the values associated with
the open message queue description as set when the message queue was
opened and as modified by subsequent mq_setattr(3C) calls:
mq_flags message queue flags
The following attributes of the message queue are returned as set at
message queue creation:
mq_maxmsg maximum number of messages
mq_msgsize maximum message size
mq_curmsgs number of messages currently on the queue.
RETURN VALUES
Upon successful completion, the mq_getattr() function returns 0. Other‐
wise, the function returns −1 and sets errno to indicate the error.
ERRORS
The mq_getattr() function will fail if:
EBADF The mqdes argument is not a valid message queue descriptor.
ENOSYS The mq_getattr() function is not supported by the system.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
msgctl(2), msgget(2), msgrcv(2), msgsnd(2), mq_open(3C), mq_send(3C),
mq_setattr(3C), mqueue.h(3HEAD), attributes(7), standards(7)
Oracle Solaris 11.4 31 Jan 2012 mq_getattr(3C)