svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
mktemp(3c)
Standard C Library Functions mktemp(3C)
NAME
mktemp, mkdtemp - make a unique file name from a template
SYNOPSIS
#include <stdlib.h>
char *mktemp(char *template);
char *mkdtemp(char *template);
DESCRIPTION
The mktemp() function replaces the contents of the string pointed to by
template with a unique file name, and returns template. The string in
template should look like a file name with six trailing 'X's. The
mktemp() function will replace the 'X's with a character string that
can be used to create a unique file name.
The mkdtemp() function makes the same replacement to the template as in
mktemp() and creates the template directory using mkdir(2), passing a
mode argument of 0700.
RETURN VALUES
The mktemp() function returns the pointer template. If a unique name
cannot be created, template points to a null string.
Upon successful completion, mkdtemp() returns the pointer template. If
a unique directory cannot be created, mkdtemp() returns a null pointer.
ERRORS
The mkdtemp() function can set errno to the same values as lstat(2) and
mkdir(2).
EXAMPLES
Example 1 Generate a filename.
The following example replaces the contents of the "template" string
with a 10-character filename beginning with the characters "file" and
returns a pointer to the "template" string that contains the new file‐
name.
#include <stdlib.h>
...
char template[] = "/tmp/fileXXXXXX";
char *ptr;
ptr = mktemp(template);
USAGE
Between the time a pathname is created and the file opened, it is pos‐
sible for some other process to create a file with the same name. The
tmpfile(3C) and mkstemp(3C) functions avoid this problem and are pre‐
ferred over this function.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
lstat(2), mkdir(2), mkstemp(3C), tmpfile(3C), tmpnam(3C),
attributes(7), standards(7)
Oracle Solaris 11.4 23 May 2016 mktemp(3C)