svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
mbsrtowcs_s(3c)
Standard C Library Functions mbsrtowcs(3C)
NAME
mbsrtowcs, mbsnrtowcs - convert a character string to a wide-character
string (restartable)
mbsrtowcs_s - wide-character string operations with additional safety
checks
SYNOPSIS
#include <wchar.h>
size_t mbsrtowcs(wchar_t *restrict dst, const char **restrict src,
size_t len, mbstate_t *restrict ps);
size_t mbsnrtowcs(wchar_t *restrict dst, const char **restrict src,
size_t nmc, size_t len, mbstate_t *restrict ps);
#define __STDC_WANT_LIB_EXT1__ 1
#include <wchar.h>
errno_t mbsrtowcs_s(size_t *restrict retval, wchar_t *restrict dst,
rsize_t dstmax, const char **restrict src, rsize_t len,
mbstate_t *restrict ps);
DESCRIPTION
The mbsrtowcs() function converts a sequence of characters, beginning
in the conversion state described by the object pointed to by ps, from
the array indirectly pointed to by src into a sequence of corresponding
wide-characters. If dst is not a null pointer, the converted characters
are stored into the array pointed to by dst. Conversion continues up to
and including a terminating null character, which is also stored. Con‐
version stops early in either of the following cases:
o When a sequence of bytes is encountered that does not form a
valid character.
o When len codes have been stored into the array pointed to by
dst (and dst is not a null pointer).
Each conversion takes place as if by a call to the mbrtowc() function.
If dst is not a null pointer, the pointer object pointed to by src is
assigned either a null pointer (if conversion stopped due to reaching a
terminating null character) or the address just past the last character
converted (if any). If conversion stopped due to reaching a terminating
null character, and if dst is not a null pointer, the resulting state
described is the initial conversion state.
If ps is a null pointer, the mbsrtowcs() function uses its own internal
mbstate_t object, which is initialized at program startup to the ini‐
tial conversion state. Otherwise, the mbstate_t object pointed to by ps
is used to completely describe the current conversion state of the
associated character sequence. Solaris will behave as if no function
defined in the Solaris Reference Manual calls these functions.
The mbsnrtowcs() function is equivalent to the mbsrtowcs() function,
except that the conversion of characters pointed to by src is limited
to at most nmc bytes (the size of the input buffer).
The behavior of these functions are affected by the LC_CTYPE category
of the current locale. See environ(7).
The mbsrtowcs_s() function is part of the bounds checking interfaces
specified in the C11 standard, Annex K. It is similar to mbsrtowcs() in
that it converts a sequence of multibyte characters into a sequence of
corresponding wide characters, but with additional safety checks for
explicit runtime constraints as defined by the C11 standard. See run‐
time_constraint_handler(3C) and INCITS/ISO/IEC 9899:2011.
RETURN VALUES
If the input conversion encounters a sequence of bytes that do not form
a valid character, an encoding error occurs. In this case, these func‐
tions store the value of the macro EILSEQ in errno and returns
(size_t)-1; the conversion state is undefined. Otherwise, it returns
the number of characters successfully converted, not including the ter‐
minating null (if any).
Additionally, if there is no runtime-constraint violation, the mbsr‐
towcs_s() function returns zero. Otherwise, it returns a non-zero
value.
ERRORS
The mbsrtowcs() function will fail if:
EINVAL The ps argument points to an object that contains an invalid
conversion state.
EILSEQ Invalid character sequence is detected.
The mbsrtowcs_s() function will fail if:
EINVAL Null pointer is passed or source and destination overlaps.
ERANGE size argument is not a valid value.
EOVERFLOW Destination array is too small.
EILSEQ Illegal byte sequence.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSee NOTES below
_ StandardSee standards(7).
SEE ALSO
mbrtowc(3C), mbsinit(3C), setlocale(3C), attributes(7), environ(7),
standards(7)
NOTES
If ps is not a null pointer, mbsrtowcs() and mbsnrtowcs() use the xmb‐
state_t object pointed to by ps and the functions can be used safely in
multithreaded applications. If ps is a null pointer, mbsrtowcs() and
mbsnrtowcs() use their internal mbstate_t object and the function is
Unsafe in multithreaded applications.
The mbsrtowcs() function can be used safely in multithreaded applica‐
tions.
The mbsrtowcs_s() function cannot be used safely in a multithreaded
application due to the runtime constraint handler. For more informa‐
tion, see the runtime_constraint_handler(3C) man page.
Oracle Solaris 11.4 11 Jun 2018 mbsrtowcs(3C)