svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
makedev(3c)
Standard C Library Functions makedev(3C)
NAME
makedev, major, minor - manage a device number
SYNOPSIS
#include <sys/types.h>
#include <sys/mkdev.h>
dev_t makedev(major_t maj, minor_t min);
major_t major(dev_t device);
minor_t minor(dev_t device);
minor_t maxminor();
DESCRIPTION
The makedev() function returns a formatted device number on success and
NODEV on failure. The maj argument is the major number. The min argu‐
ment is the minor number. The makedev() function can be used to create
a device number for input to mknod(2).
The major() function returns the major number component from device.
The minor() function returns the minor number component from device.
The maxminor() function returns the maximum supported minor number.
RETURN VALUES
Upon successful completion, makedev() returns a formatted device num‐
ber. Otherwise, NODEV is returned and errno is set to indicate the
error.
ERRORS
The makedev() function will fail if:
EINVAL One or both of the arguments maj and min is too large, or the
device number created from maj and min is NODEV.
The major() function will fail if:
EINVAL The device argument is NODEV, or the major number component
of device is too large.
The minor() function will fail if:
EINVAL The device argument is NODEV.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
mknod(2), stat(2), attributes(7), getmaxminor(9F)
Oracle Solaris 11.4 28 Oct 2014 makedev(3C)