mac_ring_info(9s) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

mac_ring_info(9s)

Kernel & Driver Data Structures                              mac_ring_info(9S)



NAME
       mac_ring_info - ring information data structure

SYNOPSIS
       #include <sys/mac_provider.h>

INTERFACE LEVEL
       Solaris architecture specific (Solaris DDI)

DESCRIPTION
       The  mac_ring_info  structure  is  used  by  a network device driver to
       describe it's RX and TX rings. The structure is used as an argument  to
       the mr_rget(9E) driver entry point when querying the ring.

STRUCTURE MEMBERS
         mac_ring_driver_t       mri_driver;
         mac_ring_start_t        mri_start;
         mac_ring_stop_t         mri_stop;
         mac_intr_enable_t       mri_intr_enable;
         mac_intr_disable_t      mri_intr_disable;
         ddi_intr_handle_t       mri_intr_ddi_handle;
         mac_ring_send_t         mri_tx;
         mac_ring_poll_t         mri_poll;
         mac_ring_stat_t         mri_stat;
         uint_t                  mri_flags;


       mri_driver             Filled  by  the driver as handle to the driver's
                              ring structure.


       mri_start              The driver entry point for starting  a  driver's
                              ring.


       mri_stop               The  driver  entry  point  for stopping a driver
                              ring.


       mri_stat               The driver entry point  for  getting  statistics
                              for ring.


       mrii_tx                The  driver  entry point for transmitting packet
                              for TX rings.


       mri_poll               The driver entry point for polling RX  ring  for
                              packets.


       mri_flags              A set of flags for describing ring behavior.


       mri_intr_ddi_handle    The  DDI  interrupt  handle  associated with the
                              interrupt for this ring.


       mri_intr_enable        For RX  rings,  this  driver  entry  point  will
                              enable   interrupts  again  and  transition  the
                              driver polling to interrupt mode.


       mri_intr_disable       For RX rings, this driver entry point will  dis‐
                              able   interrupts  and  place  the  driver  into
                              polling mode.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE  VALUE _ Availabilitysystem/header _ Interface StabilityCommit‐
       ted


SEE ALSO
       attributes(7),         mac_capab_rings(9E),         mac_group_info(9E),
       mac_ring_info(9E), mr_rget(9E), ddi_intr_alloc(9F), mac_register(9S)



Oracle Solaris 11.4               9 Dec 2011                 mac_ring_info(9S)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3