mac_group_info(9s) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

mac_group_info(9s)

Kernel & Driver Data Structures                             mac_group_info(9S)



NAME
       mac_group_info - group Information data structure

SYNOPSIS
       #include <sys/mac_provider.h>

INTERFACE LEVEL
       Solaris architecture specific (Solaris DDI)

DESCRIPTION
       The  mac_group_info  structure  is  used  by a network device driver to
       describe its ring groups and the groups capabilities. The structure  is
       used  as the argument to the mr_gget(9E) driver entry point when query‐
       ing the group and its capabilities.

STRUCTURE MEMBERS
         mac_group_driver_t              mgi_driver;
         mac_group_start_t               mgi_start;
         mac_group_stop_t                mgi_stop;
         uint_t                          mgi_count;
         mac_group_flags_t               mgi_flags;
         mac_group_addmac_t              mgi_addmac;
         mac_group_remmac_t              mgi_remmac;
         mac_group_addvlan_t             mgi_addvlan;
         mac_group_remvlan_t             mgi_remvlan;
         mac_group_setmtu_t              mgi_setmtu;
         mac_group_getsriov_info_t       mgi_getsriov_info;


       mgi_driver           Filled by the driver as  handle  to  the  driver's
                            group structure.


       mgi_start            The  driver  entry  point  for starting a driver's
                            ring group.


       mgi_stop             The driver entry point for stopping a driver  ring
                            group.


       mgi_count            The  number of rings that are members of this ring
                            group.


       mgi_flags            Set by the driver to indicate various  ring  group
                            capabilities  including  whether  the group is the
                            default ring group for the interface, whether  the
                            group  is  a pool of non-active rings, whether the
                            group implements tagging/stripping for all  VLANs,
                            or implements transparent VLANs.


       mgi_addmac           The  driver  entry  point to program a MAC address
                            into the driver's hardware for  this  ring  group.
                            This  entry is only for RX ring groups. For SRIOV-
                            capable  devices,  the   MAC_GROUP_MACADDR_PRIMARY
                            flag  will  be  used  to identify which of the MAC
                            addressed for the group is the primary MAC address
                            of the VF.


       mgi_remmac           The driver entry point to remove a previously pro‐
                            grammed MAC address.


       mgi_addvlan          The driver entry point to add a VLAN filter to the
                            ring  group.  The  MAC_VLAN_FILTER_TAG_ENABLE flag
                            will be set  if  the  group  is  to  provide  tag‐
                            ging/stripping offload.


       mgi_remvlan          The driver entry point to remove a VLAN filter.


       mgi_setmtu           The  driver  entry  point for the MAC layer to set
                            the MTU for the ring group.


       mgi_getsriov_info    The driver entry point to get the  SRIOV  informa‐
                            tion associated with this group.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/header _ Interface  StabilityCommit‐
       ted


SEE ALSO
       attributes(7),  mac_capab_rings(9E),  mac_group_info(9E),  mr_gget(9E),
       mac_register(9S)



Oracle Solaris 11.4               14 Dec 2011               mac_group_info(9S)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3