mac_capab_rings(9s) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

mac_capab_rings(9s)

Kernel & Driver Data Structures                            mac_capab_rings(9S)



NAME
       mac_capab_rings - rings capability data structure

SYNOPSIS
       #include <sys/mac_provider.h>

INTERFACE LEVEL
       Solaris architecture specific (Solaris DDI)

DESCRIPTION
       The  mac_capab_rings  structure  is  used by a network device driver to
       describe its rings capability. The structure is used as the argument to
       the    mc_getcapab(9E)   driver   entry   point   when   querying   the
       MAC_CAPAB_RINGS capability.

STRUCTURE MEMBERS
         mac_ring_type_t         mr_type;
         mac_group_type_t        mr_group_type;
         uint32_t                mr_flags;
         mac_rings_version_t     mr_version;
         uint_t                  mr_rnum;
         uint_t                  mr_gnum;
         mac_get_ring_t          mr_rget;
         mac_get_group_t         mr_gget;
         mac_group_add_ring_t    mr_gaddring;
         mac_group_rem_ring_t    mr_gremring;



       The following fields of the mac_capab_rings structure are set to  indi‐
       cate the device's rings capability:

       mr_type          Set by MAC layer to indicate which driver resources is
                        being    queried.    Possible    ring    types     are
                        MAC_RING_TYPE_RX or MAC_RING_TYPE_TX.


       mr_group_type    Set  by  the  driver to indicate whether the device is
                        capable of static or dynamic ring  grouping.  Possible
                        grouping      types     for     the     driver     are
                        MAC_GROUP_TYPE_STATIC  or  MAC_GROUP_TYPE_DYNAMIC.  If
                        the  driver  can  dynamically  grow  and  shrink  ring
                        groups,    then    it     should     advertise     the
                        MAC_GROUP_TYPE_DYNAMIC   group   type   and  implement
                        mr_gaddring() and mr_gremring() entry points.


       mr_flags         Set by the driver to indicate various conditions. Cur‐
                        rently,  MAC_RINGS_VLAN_TRANSPARENT  is  the  possible
                        value to indicate the hardware is capable of transpar‐
                        ent VLANs.


       mr_version       Set by the driver to indicate the version of the rings
                        capability that the  driver  implements.  The  current
                        revision level is MAC_RINGS_VERSION_1.


       mr_rnum          Set  by  the driver to indicate the total number of RX
                        or TX rings the driver implements.


       mr_gnum          Set by the driver to indicate the total number  of  RX
                        or TX ring groups the hardware implements.


       mr_rget          A  driver entry point to get specific ring information
                        for each RX and TX ring the hardware implements.


       mr_gget          A driver entry point to get the  specific  information
                        for each RX and TX ring group the driver implements.


       mr_gaddring      A  driver  entry  point to add a ring to a driver ring
                        group. This entry point is implemented for drivers who
                        support dynamic ring grouping.


       mr_gremring      A  driver entry point to remove a specific ring from a
                        driver ring group.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE  TYPEAT‐
       TRIBUTE  VALUE _ Availabilitysystem/header _ Interface StabilityCommit‐
       ted


SEE ALSO
       attributes(7),   mac_capab_rings(9E),   mac_group_info(9E),   mc_getca‐
       pab(9E), mac_register(9S)



Oracle Solaris 11.4               16 Jun 2011              mac_capab_rings(9S)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3