mac_capab_rings(9e) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

mac_capab_rings(9e)

mac_capab_rings(9E)           Driver Entry Points          mac_capab_rings(9E)



NAME
       mac_capab_rings, mr_rget, mr_gget, mr_gaddring, mr_gremring - MAC capab
       rings driver entry points

SYNOPSIS
       #include <sys/mac_provider.h>

       void prefix_ring_get(void *driver_handle, mac_ring_type_t rtype,
            int group_index, int ring_index, mac_ring_info_t *rinfop,
            mac_ring_handle_t ring_handle);


       void prefix_group_get(void *driver_handle, mac_ring_type_t rtype,
            int group_index, mac_group_info_t *ginfop,
            mac_group_handle_t group_handle);


       void prefix_group_add_ring(mac_group_driver_t group_handle,
            mac_ring_driver_t ring_handle, mac_ring_type_t rtype);


       void prefix_group_remove_ring(mac_group_driver_t group_handle,
            mac_ring_driver_t ring_handle, mac_ring_type_t, rtype);

PARAMETERS
       driver_handle    Pointer to the driver-private handle which was  speci‐
                        fied  by  the device driver through the m_driver field
                        of the mac_register(9S) structure during registration.


       rtype            The ring type being queried, either RX or TX rings.

                        MAC_RING_TYPE_TX for TX rings or TX ring groups.

                        MAC_RING_TYPE_RX for RX rings or RX ring groups.


       group_index      The ring group index supplied  by  the  MAC  layer  to
                        query  a  specific  driver ring group. The group index
                        should not exceed the number of ring  groups  reported
                        in response to a MAC_CAPAB_RINGS query.


       ring_index       The  ring  index  supplied by the MAC layer to query a
                        specific ring. The ring index should  not  exceed  the
                        number of rings reported in a MAC_CAPAB_RINGS query.


       rinfop           The  mac_ring_info(9S)  structure  to be filled by the
                        driver for the mac layer. This structure provides  the
                        MAC  layer  the  specific  information  it requires to
                        manipulate this specific driver ring.


       ginfop           The mac_group_info(9S) structure to be filled  by  the
                        driver  for the mac layer. This structure provides the
                        MAC layer the  specific  information  it  requires  to
                        manipulate this specific driver ring group.


       group_handle     An  opaque handle to the MAC layer's representation of
                        this ring group.


       ring_handle      An opaque handle to the MAC layer's representation  of
                        this ring.


INTERFACE LEVEL
       Solaris architecture specific (Solaris DDI).

DESCRIPTION
       The  entry  points  described below are implement the MAC device driver
       and passed to the MAC layer through the  mac_capab_rings  structure  as
       part of the response to a MAC_CAPAB_RINGS request from the MAC layer.


       The   mr_gget()   function   requests   the   driver  to  fill  in  the
       mac_group_info structure in response to the MAC layer.  The  MAC  layer
       then  uses  the  response  to  further manipulate the ring group of the
       driver.


       The mr_rget() function requests the driver to fill in the mac_ring_info
       structure  in  response  to  the MAC layer. The MAC layer then uses the
       response to further manipulate a ring controlled by the driver.


       The mr_gaddring() function adds the specified  ring  to  the  specified
       ring  group. This action should be implemented only in MAC drivers that
       implement dynamic ring grouping as described in mac_capab_rings(9S).


       The mr_gremring() function removes the specified ring from  the  speci‐
       fied  ring group. This action should be implemented only in MAC drivers
       that   implement   dynamic    ring    grouping    as    described    in
       mac_capab_rings(9S).

RETURN VALUES
       None of these entry points have return values.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       tab()  box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
       TRIBUTE VALUE _ Availabilitysystem/header _ Interface  StabilityCommit‐
       ted


SEE ALSO
       attributes(7),   mac_capab_rings(9S),   mac_group_info(9S),  mac_regis‐
       ter(9S), mac_ring_info(9S)



Oracle Solaris 11.4               14 Nov 2011              mac_capab_rings(9E)
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3