svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
m_label(3tsol)
Trusted Extensions Library Functions m_label(3TSOL)
NAME
m_label, m_label_alloc, m_label_dup, m_label_free - m_label functions
SYNOPSIS
cc [flag...] file... -ltsol [library...]
#include <tsol/label.h>
m_label_t *m_label_alloc(const m_label_type_t label_type);
int m_label_dup(m_label_t **dst, const m_label_t *src);
void m_label_free(m_label_t *label);
DESCRIPTION
The m_label_alloc() function allocates resources for a new label. The
label_type argument defines the type for a newly allocated label. The
label type can be:
MAC_LABEL A Mandatory Access Control (MAC) label.
USER_CLEAR A user clearance.
The m_label_dup() function allocates resources for a new dst label. The
function returns a pointer to the allocated label, which is an exact
copy of the src label. The caller is responsible for freeing the allo‐
cated resources by calling m_label_free().
The m_label_free() function frees resources that are associated with
the previously allocated label.
RETURN VALUES
Upon successful completion, the m_label_alloc() function returns a
pointer to the newly allocated label. Otherwise, m_label_alloc()
returns NULL and errno is set to indicate the error.
Upon successful completion, the m_label_dup() function returns 0. Oth‐
erwise, -1 is returned and errno is set to indicate the error.
ERRORS
The m_label_alloc() function will fail if:
EINVAL Invalid parameter.
ENOMEM The physical limits of the system are exceeded by size bytes
of memory which cannot be allocated.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
libtsol(3LIB), label_to_str(3TSOL), str_to_label(3TSOL), label_encod‐
ings(5), attributes(7), labels(7)
NOTES
The functionality described on this manual page is available only if
the system is configured with Trusted Extensions.
Oracle Solaris 11.4 23 Aug 2011 m_label(3TSOL)